您現在的位置: 大智慧股民之家 >> 股票知識 >> 股票公式 >> 公式編寫 >> 正文
大智慧公式教程:大智慧數學函數的運用
2008-7-31 來源:互聯網 字號:【

大智慧數學函數的運用

1、ABS 絕對值 求絕對值。 用法:ABS(X)返回X的絕對值。 例如:ABS(-34)返回34。請看下面指標:
{真實量比}
V1:=AMOUNT/10000;
對敲: FINANCE(33), POINTDOT,colorffcc66;
Var1:=ref(c,1);
var2:=(var1-l)/(h-l);
var3:=v1*var2;
var4:=V*var2;
var5:=abs(var4);{返回var4}
var6:=abs(var3);{返回var3}
var7:=abs(v1-var6);{返回v1-var6差}
大單賣盤:abs(v-var5)/100,color00ffff;{返回v-var5差除100}
買盤:var3/100,colorff00ff;
成交金額:V1/1000,color00ff00;
買賣盤比%:abs(v-var3)/v*100,colorc0c0c0;{返回v-var3差}
stickline(c>0,0,var6,5,0),colorffff00;{畫天蘭色柱}
換手:100*v/capital,colorred;
STICKLINE(換手<3,var6,v1 ,5 ,0),colorred;{畫紅色柱}
STICKLINE(換手>=3 and 換手<7,var6, V1,5.5,0),coloryellow;{畫黃色柱}
STICKLINE(換手>=7,var6, V1, 4,0) ,color00ff00;{畫綠色柱}

2、BETWEEN 介于 介于兩個數之間。 用法:BETWEEN(A,B,C),表示A處于B和C之間時返回1,否則返回0。 例如:BETWEEN(CLOSE,MA(CLOSE,10),MA(CLOSE,5)),

表示收盤價介于5日均線和10日均線之間。請看下面指標:
{智慧探莊 參數:下%:1 100 5 上%:1 100 5}
VAR1:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR2:=SMA(VAR1,9,1);
A:SMA(VAR2,5,1),Color00FFFF;
B:SMA(A,3,1),ColorFF00FF;
F:(3)*(A)-(2)*(B),Color00FF00;
趨勢線:MA(CLOSE,20)-(MA(CLOSE,20))/(3),ColorFFFFFF;
X:=((CLOSE)/(趨勢線)-1)*(100);
AA:=BETWEEN(X,下%,上%);{表示x介于參數下%,上%之間}
智慧探莊:IF((AA>0),5,80),ColorFFFF00;
VAR3:=(MA(WINNER(CLOSE),5))*(100);
智慧出擊:=(CROSS(VAR3,2.5))*(85);
出擊:IF((智慧出擊>0),60,0),Color0000FF;
BB:IF(((智慧出擊>0) or (出擊>0)),2,20),Color008000,Stick;

3、LONGCROSS 維持交叉函數 兩條線維持一定周期后交叉。 用法:LONGCROSS(A,B,N)表示A在N周期內都小于B,本周期從下方向上穿過B時返回1,否則返回0。

例如:LONGCROSS(MA(CLOSE,5),MA(CLOSE,10),5),表示5日均線維持5周期后與10日均線金叉。

4、CEILING 向上舍入 向數值增大方向舍入。 用法:CEILING(A)返回沿A數值增大方向最接近的整數。 例如:CEILING(12.3)求得13,CEILING(-3.5)求得-3。
5、FLOOR 向下舍入 向數值減小方向舍入。 用法:FLOOR(A)返回沿A數值減小方向最接近的整數。 例如:FLOOR(12.3)求得12,FLOOR(-3.5)求得-4。CEILING與

FLOOR用法一樣,區別在于向上舍入和向下舍入。
下面指標用到了這幾個函數:
aa1:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100+50;
aa2:=EMA(aa1,9);
aa3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
aa4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
aa5:=SMA(aa4,13,8);
走勢:CEILING(SMA(aa5,13,8));{向上舍入 向數值增大方向舍入,aa5的13日均線求得8}
aa6:=SMA(aa3,21,8);
買觀注: STICKLINE(走勢-aa6<-65,0,5,15,1);
買進:=LONGCROSS(aa1,aa2*1.05,15) AND aa1<40;{表示aa1維持aa2*1.05后與15日金叉}
賣觀注: STICKLINE(走勢-aa6>85,95,90,15,1);
賣出:STICKLINE(LONGCROSS(aa2,aa1*0.95,7) AND aa1>0,100,80,6,0),color00ff00;{表示aa2維持aa1*0.95后與7日死叉,畫綠色柱線}

6、MAX 最大值 求最大值。 用法:MAX(A,B)返回A和B 中的較大值。 例如:MAX(CLOSE-OPEN,0),表示若收盤價大于開盤價返回它們的差值,否則返回0。

7、MIN 最小值 求最小值。 用法:MIN(A,B)返回A和B中的較小值。 例如:MIN(CLOSE,OPEN),返回開盤價和收盤價中的較小值。這2個函數通常成雙成對使用,

請看下面指標:
Var1:=(HIGH+LOW+CLOSE)/3;{(最高價+最低價+收盤價)/3}
Var2:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));{條件函數(最高價=最低價,1,最高

價-最大值(開盤價,收盤價))}
Var3:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-Var1);{條件函數(最高價=最低價,1,最大值(收盤價,開盤價)-Var1)}
Var4:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);{條件函數(最高價=最低價,1,最小值(開盤價,收盤價)-最低價)}
Var5:=IF(HIGH=LOW,1,Var1-MIN(CLOSE,OPEN));{條件函數(最高價=最低價,1,Var1-最小值(收盤價,開盤價))}
Var6:=VOL/IF(HIGH=LOW,4,HIGH-LOW);{成交量/條件函數(最高價=最低價,4,最高價-最低價)}
Var7:=Var2*Var6;
Var8:=Var3*Var6;
Var9:=Var4*Var6;
VarA:=Var5*Var6;
STICKLINE(CLOSE>0,0,Var7+VarA,4,1),COLORRED;{畫柱線(收盤價>0,0,Var7+VarA,4,1),紅色柱}
買入量: Var7+VarA,POINTDOT,COLORRED;{紅色點狀線}
STICKLINE(CLOSE>0,(Var8+Var9)*(-1),0,4,1),COLORFFCCCC;{畫柱線(收盤價>0,(Var8+Var9)*(-1),0,4,1),淡青色柱}
賣出量:(Var8+Var9)*(-1),POINTDOT,COLORFFCCCC;{淡青色點狀線}
 

8、MOD 求模運算 求模運算。 用法:MOD(A,B)返回A對B求模。 例如:MOD(26,10)返回6。

9、INTPART 取整 絕對值減小取整,即取得數據的整數部分。 用法:INTPART(A)返回沿A絕對值減小方向最接近的整數。 例如:INTPART(12.3)求得12,INTPART

(-3.5)求得-3。下面的指標用到了這兩個函數;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;{(收盤價-最低值(最低價,9))/(最高值(最高價,9)-最低值(最低價,9))*100}
K:=(SMA(RSV,3,1));{(移動平均(RSV,3,1))}
D:=(SMA(K,3,1));{(移動平均(K,3,1))}
KK:=INTPART(SMA(RSV,3,1));{取整(移動平均(RSV,3,1))}
DD:=INTPART(SMA(K,3,1));{取整(移動平均(K,3,1))}
N:KK+DD,LINETHICK2,COLORff00ff;{畫粗粉色線}
精確漲停:IF(CROSS(N,50),90,50),,COLORYELLOW;{條件函數(交叉函數(N,50),90,50)畫黃色線}
接近頭部:IF(CROSS(160,N),95,160),,COLOR00ff00;{條件函數(交叉函數(160,N),95,160)畫綠色線}
尾數:MOD(n,10),LINETHICK0,COLORWHITE;{求模運算(n,10)畫白色線}
N的尾數:IF(尾數=0,65,25),,COLORFFCC66;{條件函數(尾數=0,65,25)畫青色線}

10、NOT 求邏輯非。 用法:MOT(X)返回非X,即當X=0時返回1,否則返回0。 例如:MOT(ISUP)表示平盤或收陰。請看這個函數在指標中的用法:
Var1:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇線:= MA((CLOSE-Var1)/Var1,1);
買點:IF(REF(神奇線,2)=LLV(神奇線,20) AND REF(神奇線,2)<0.071 AND REF(神奇線,2)<REF(神奇線,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF

(HIGH,1)) AND CLOSE>REF(CLOSE,1),0.5,0);{這句用到了MOT函數}

11、RANGE 范圍 介于某個范圍之間。 用法:RANGE(A,B,C)表示A大于B同時小于C時返回1,否則返回0。 例如:RANGE(CLOSE,MA(CLOSE,5),MA(CLOSE,10))表示

收盤價大于5日均線并且小于10日均線。請看下面指標:
a1:=1;
a2:=ma(c,30);
a3:=(c-a2)/a2*100;
a4:=ma(a3,3);
a5:=a1-1.01*1000000;
a6:=barslast(cross(-10,a4)=1);
a7:=if(a4<-10 and a6>=5,a4,0),colorwhite;
機會:a7,colorstick,colorffff00;{畫青色柱線}
a8:=range(a5,(1-0.618)*1000,(1+1.9/100)*1000);{在這句中用到了mange函數,其格式含義請慢慢體會}
drawtext(filter(a7=a4 and a8=0,8)=1,a7*1.2 ,'注意反彈'),coloryellow;

12、REVERSE 求相反數 求相反數。 用法:REVERSE(X)返回-X。 例如:REVERSE(CLOSE)返回-CLOSE。請看指標:
Var1:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
Var2:=HHV(HIGH,60);
VarA:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VarB:=SMA(VarA,5,1);
VarC:=SMA(VarB,3,1);
跌: Var2*0.382,colorwhite;
底部: REVERSE(IF(CROSS(VarB,VarC) AND VarC<10 AND Var1<-30,跌*2,-5)),color00ff00;{返回CROSS(VarB,VarC)}
DRAWTEXT(REVERSE(CROSS(VarB,VarC)) AND VarC<10 AND Var1<-30,跌-5,'底部'),color00ff00;{返回CROSS(VarB,VarC)}

13、ATAN 反正切值 用法:ATAN(X)返回X的反正切值。請看指標:
lc1:=ma(c,9);
jxjd:=atan((lc1-ref(lc1,1))/ref(lc1,1)*100)/3.1416*180;{返回((lc1-ref(lc1,1))的反正切值}
smk:sma(jxjd,3,1),colorstick;{畫柱線}
smd:sma(smk,3,1);smk;

14、EXP 指數 用法:EXP(X)為e的X次冪。 例如:EXP(CLOSE)返回e的CLOSE次冪。

15、LOG 以10為底的對數 用法:LOG(X)取得X的對數。 例如:LOG(100)等于2。下面指標用到了這兩個函數:
Var1:=IF(VOL/CAPITAL>0.001,1,EXP(ABS(LOG(VOL/CAPITAL*100))));{返回e的(ABS(LOG(VOL/CAPITAL*100)))次冪}
STICKLINE(Var1>2 AND VOL<MA(VOL,5)/2,0,VOL,4,0),COLORFF00FF;{畫柱線}
相對地量:0,COLORFF00FF;

16、POW 乘冪 用法:POW(A,B)返回A的B次冪。 例如:POW(CLOSE,3)求得收盤價的3次方。請看預測指標:
Var2:=EMA(CLOSE,100)-EMA(CLOSE,50);
Var3:=EMA(Var2,60);
Var4:=(Var2-Var3)*2;
ZX: IF( Var4>0.3,POW(Var4,3)*10/10+POW(Var4,2),0);
ZY: EMA(ZX,3);
LING: 0;

17、SQRT 開平方 用法:SQRT(X)為X的平方根。 例如:SQRT(CLOSE)收盤價的平方根。請看指標:
底(-SQRT(SQRT(FLOOR(SQRT((MA(((1)/(WINNER(CLOSE)))*(100),4))/(10000)))))))*(5)),Color4455EE;
STICKLINE((底<(-2)),0,底,1.5,1),Color2222FF;

18、SIN 正弦值 用法:SIN(X)返回X的正弦值。

19、COS 余弦值 用法:COS(X)返回X的余弦值。正弦波是自然界最常見的波形。正弦波和余弦波的波形是一樣的,無非是相差π/2弧度(90度)的相位。
主要應用在技術分析中的周期分析上。那么在指標中畫出正弦波應該是很容易了吧。看看這2個函數在指標中的運用:
A:=COUNT(C,0)=1;
B:=BARSLAST(A);{1,2,3,4,.....}
正弦值:SIN(B);
余弦值:COS(B);
正余平方和:POW(正弦值,2)+POW(余弦值,2);
正弦180度:SIN(3.1415926);
但是看起來不太光滑.究其原因,是因為正弦波的周期是2π,當X取值較大時(1,2,3,...)時,返回值就不太“精密”了,也就是說構成波形的點數不夠。這個就

好辦了,我們可以把數列的值都減小N倍,再來看看效果。
A:=COUNT(C,0)=1;
B:=BARSLAST(A)/N;{參數N:1 999 10}
正弦值:SIN(B);
余弦值:COS(B);
調整參數N,就可以發現,N取值越大,波形就越光滑。當N取3時,就有不錯的光滑度。當N取10時,就非常光滑了。N調整得越大,在2π周期中的點數就越多,一

個完整波形的周期內所含的日期差(在日K線中)就越大了。

20、TAN 正切值 TAN(X)返回X 的正切值。正切值的絕對值,最小是0,最大趨向于無窮大。當正弦值接近1時,正切值接近于無窮大。請看:
A:=COUNT(C,0)=1;
B:=BARSLAST(A)/N;{參數N:1 999 10}
正弦值:SIN(B);
余弦值:COS(B);
TAN(B);
以下幾個函數很少用到,做一下簡單了解就行了。你可以挖掘這幾個函數的運用,也許會有出乎意料的收獲。

21、ASIN 反正弦值 用法:ASIN(X)返回X的反正弦值。

22、SGN 符號值 求符號值。 用法:SGN(X),當X>0,X<0分別順1,0,-1。

23、ACOS 反余弦值 用法:ACOS(X)返回X的反余弦值。

24、LN自然對數 求自然對數。 用法:LN(X)以e為底的對數。 例如:LN(CLOSE)求收盤價的對數。

25、SIN 正弦值 用法:SIN(X)返回X的正弦值。

  鄭重聲明:大智慧股民之家刊登〖大智慧公式教程:大智慧數學函數的運用〗一文目的在于傳播更多信息,與本網站立場無關。本版文章的原創性以及文中陳述文字和內容并未經過本站證實,大智慧股民之家不保證其內容的準確性、可靠性和有效性,僅供投資者參考,并不構成投資建議。投資者據此操作,風險自擔,并請自行核實相關內容。 如對本文內容有疑議,請及時與我們聯系。
分享到:

相關閱讀:

股票在線視頻:

江苏e球彩开奖走势图