您現在的位置: 大智慧股民之家 >> 股票知識 >> 股票公式 >> 公式編寫 >> 正文
大智慧公式教程:引用函數COUNT的運用
2008-7-26 來源:本站原創 字號:【

大智慧引用函數COUNT的運用

函數:COUNT(X,N) 參數: X為數組,N為計算周期
說明:統計N周期中滿足X條件的周期數,若N=0則從第一個有效值開始。
示例:COUNT(CLOSE>OPEN,20);表示統計20周期內收陽的周期數。看下面的指標(自己取名吧),有幾條語句用了COUNT函數:
V1:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇線:MA((CLOSE-V1)/V1,1),coloryellow,linethick2;
買點:IF(CROSS(神奇線,0) AND LOW/REF(HIGH,1)<1.012,0.5,0), STICK;
穩賺:IF(COUNT(神奇線>REF(神奇線,1),3)=3 AND COUNT(神奇線<0,10)=10 AND REF(神奇線,3)=LLV(神奇線,10),0.5,0);
V2:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
V3:=(EMA(CLOSE, 6)-EMA(CLOSE, 12))*100;
獵莊:V3<13 AND V2>9,stick,ColorFFFFFF,linethick2;
YD:=(count(c<ref(O,1),13)>=10 OR count(c<ref(c,2),13)>=10) and count(H/L>1.048,13)>=7;
DTJJ:=DMA(c,V/MA(V,13)/13);
XJPL:=c/DTJJ<0.91;
a1:=YD and XJPL;
STICKLINE(a1,0,0.50,4,1),colorffcccc;
回調買入:0,colorffcccc;
aa1:=cross(ref(c,3),ref(ma(c,20),3));
bb1:=count(c>ma(c,20),3)=3;
cc1:=cross(c,ma(c,20)) and (c-ma(c,20))/ma(c,20)>0.03;
突破月線:if((aa1 and bb1) or cc1,0.5,0),stick,linethick2,colorred;
drawicon((aa1 and bb1) or cc1,0.6,1);
指標解析:
V1:=(簡單移動平均(收盤價,80)-簡單移動平均(收盤價,13)/3);
神奇線:簡單移動平均((收盤價-V1)/V1,1),coloryellow,linethick2;{畫黃色粗線}
買點:條件函數(交叉函數(神奇線,0) AND 最低價/向前引用(最高價,1)<1.012,0.5,0), 棒狀線;{在坐標0--0.5處畫棒狀線}
穩賺:條件函數(統計總數(神奇線>向前引用(神奇線,1),3)=3 AND 統計總數(神奇線<0,10)=10 AND 向前引用(神奇線,3)=最低值(神奇線,10),0.5,0);{在坐標0--0.5處顯示脈沖信號}
V2:=(收盤價-向前引用(收盤價,1))/向前引用(收盤價,1)*100;
V3:=(指數平滑移動平均(收盤價, 6)-指數平滑移動平均(收盤價, 12))*100;
獵莊:V3<13 AND V2>9,棒狀線,ColorFFFFFF,linethick2;{默認在坐標0--1處畫白色棒狀線}
YD:=(統計總數(收盤價<向前引用(開盤價,1),13)>=10 OR 統計總數(收盤價<向前引用(收盤價,2),13)>=10) and 統計總數(最高價/最低價>1.048,13)>=7;
DTJJ:=動態移動平均(收盤價,成交量/簡單移動平均(成交量,13)/13);
XJPL:=收盤價/DTJJ<0.91;
a1:=YD and XJPL;{兩個條件同時成立}
畫柱線(a1,0,0.50,4,1),colorffcccc;{在坐標0--0.5處畫寬度為4的青色空心棒狀線}
回調買入:0,colorffcccc;{在指標圖上方顯示'回調買入'}
aa1:=交叉函數(向前引用(收盤價,3),向前引用(簡單移動平均(收盤價,20),3));
bb1:=統計總數(收盤價>簡單移動平均(收盤價,20),3)=3;
cc1:=交叉函數(收盤價,簡單移動平均(收盤價,20)) and (收盤價-簡單移動平均(收盤價,20))/簡單移動平均(收盤價,20)>0.03;
突破月線:條件函數((aa1 and bb1) or cc1,0.5,0),棒狀線,linethick2,colorred;{在坐標0--0.5處畫紅色粗棒狀線}
畫圖標((aa1 and bb1) or cc1,0.6,1);{在坐標0.6處顯示紅臉}
下面是幾個運用COUNT函數的指標例句:
(1)、n日內陰線多于陽線
     count(open>close,n)/n<0.5;
注:n為指標參數,可在參數設定范圍內設定參數范圍。同時可以自由編輯里面的數值(如0.5等,達到確定陰線占全部K線個數的比例)。
(2)、n日內陽線多于陰線
   count(open<close,n)/n>0.5;
注:n為指標參數,可在參數設定范圍內設定參數范圍。同時可以自由編輯里面的數值(如0.5等,達到確定陽線占全部K線個數的比例)。
(3)、n日內上漲多于下跌(第二天開盤高于前一天收盤)
       count(c>ref(c,1),n)/n>0.5;
注:n為指標參數,可在參數設定范圍內設定參數范圍。同時可以自由編輯里面的數值(如0.5等,達到確定其中比例)。
(4)、n日內上漲少于下跌(第二天開盤低于前一天收盤)
     count(c>ref(c,1),n)/n<0.5;
注:n為指標參數,可在參數設定范圍內設定參數范圍。同時可以自由編輯里面的數值(如0.5等,達到確定其中比例)。
(5)、連續n日收陽線
  up:=close>open;
       count(up,n)=n;
注:count(x,n),統計n周期中滿足x條件的周期數,若n=0則從第一個有效值開始。n為指標參數,可在參數設定范圍內設定參數范圍。
(6)、連續n日內收陰線
  up:=close<open;
       count(up,n)=n;
注:count(x,n),統計n周期中滿足x條件的周期數,若n=0則從第一個有效值開始。N為指標參數,可在參數設定范圍內設定參數范圍。
(7)、連續n天上漲
   count(close>ref(close,1),n)=n;
注:count(x,n),統計n周期中滿足x條件的周期數,若n=0則從第一個有效值開始。N為指標參數,可在參數設定范圍內設定參數范圍。
(8)、連續n天下跌
   count(c<ref(c,1),n)=n;
注:count(x,n),統計n周期中滿足x條件的周期數,若n=0則從第一個有效值開始。N為指標參數,可在參數設定范圍內設定參數范圍。
以上的參數n只要添入你所需要的周期數即可,如5、10、30等日期就是一個完整的指標或選股指標。

          股市的不隨機規律,隱藏在統計概率之中。用這兩個函數,可以統計很多概率性的規律。
比如,以兩天的收盤價相比,昨天是下跌的,今天的下跌的概率是多少?看下面指標:
{當日升跌概率}
A:=C<REF(C,1);
B:=REF(A,1) AND C>REF(C,1);{昨天下跌,今天上漲}
D:=REF(A,1) AND C=REF(C,1);{昨天下跌,今天平盤}
E:=REF(A,1) AND C<REF(C,1);{昨天下跌,今天下跌}
F:=COUNT(B,0)+COUNT(D,0)+COUNT(E,0);
上升概率:100*COUNT(B,0)/F;
下跌概率:100*COUNT(E,0)/F;
平盤概率:100*COUNT(D,0)/F;
那么連跌兩天之后,第三天收盤的各種概率是多少?看下面指標:
A:=C<REF(C,1) and ref(c,1)<ref(c,2);
B:=REF(A,1) AND C>REF(C,1);{前兩天下跌,今天上漲}
D:=REF(A,1) AND C=REF(C,1);{前兩天下跌,今天平盤}
E:=REF(A,1) AND C<REF(C,1);{前兩天下跌,今天下跌}
F:=COUNT(B,0)+COUNT(D,0)+COUNT(E,0);
上升概率:100*COUNT(B,0)/F;
下跌概率:100*COUNT(E,0)/F;
平盤概率:100*COUNT(D,0)/F;
從指數的輸出看,概率更明顯了。
連跌三天之后呢?看下面指標:
A:=C<REF(C,1) and ref(c,1)<ref(c,2) and ref(c,2)<ref(c,3);
B:=REF(A,1) AND C>REF(C,1);{前三天下跌,今天上漲}
D:=REF(A,1) AND C=REF(C,1);{前三天下跌,今天平盤}
E:=REF(A,1) AND C<REF(C,1);{前三天下跌,今天下跌}
F:=COUNT(B,0)+COUNT(D,0)+COUNT(E,0);
上升概率:100*COUNT(B,0)/F;
下跌概率:100*COUNT(E,0)/F;
平盤概率:100*COUNT(D,0)/F;
規律就更明顯了。
不要小看這些數據。雖然沒有有些“高手”做出的成功率達百分之九十左右的公式那么夸張,但很有意義的。要知道股市中的隨機因素太多,平衡性很強,稍稍的統計偏向,足可作為有用的參考。

  鄭重聲明:大智慧股民之家刊登〖大智慧公式教程:引用函數COUNT的運用〗一文目的在于傳播更多信息,與本網站立場無關。本版文章的原創性以及文中陳述文字和內容并未經過本站證實,大智慧股民之家不保證其內容的準確性、可靠性和有效性,僅供投資者參考,并不構成投資建議。投資者據此操作,風險自擔,并請自行核實相關內容。 如對本文內容有疑議,請及時與我們聯系。
分享到:

相關閱讀:

股票在線視頻:

江苏e球彩开奖走势图