您現在的位置: 大智慧股民之家 >> 股票知識 >> 股票公式 >> 公式編寫 >> 正文
大智慧公式教程:引用函數FILTER、SUMBARS運用
2008-7-26 來源:本站原創 字號:【

大智慧引用函數FILTER、SUMBARS運用

1、函數:FILTER 信號過濾 過濾連續出現的信號。 用法:FILTER(X,N),X滿足條件后,刪除其后N周期內的數據置為0。 例如:FILTER(CLOSE>OPEN,5),查找陽

線,5天內再次出現的陽線不被記錄在內。請看下面指標:
頂底背離:0,COLORYELLOW;
A1:=BARSLAST(ref(cross("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1));
B1:=ref(c,A1+1)>c and ref("macd.diff"(12,26,9),A1+1)<"macd.diff"(12

,26,9) and cross("macd.diff"(12,26,9),"macd.dea"(12,26,9));
MACD底背離:STICKLINE(FILTER(B1>0,5),0,0.75,3,0),COLOR00FF00;{5天內B1>0的條件不被記錄在內,在當前周期內出現B1>0畫綠色柱線}
DRAWTEXT(FILTER(B1>0,5),0.57,'MACD底背離'),COLOR00FF00;
A2:=BARSLAST(ref(cross("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1));
B2:=ref(c,A2+1)>c and ref("kdj.k"(9,3,3),A2+1)<"kdj.k"(9,3,3) and cross("kdj.k"(9,3,3),"kdj.d"(9,3,3));
KDJ底背離:STICKLINE(FILTER(B2>0,5),0,1,3,0),COLORYELLOW;{5天內B2>0的條件不被記錄在內,在當前周期內出現B>0畫黃色柱線}
DRAWTEXT(FILTER(B2>0,5),0.80,'KDJ底背離'),COLORYELLOW;
A3:=BARSLAST(ref(cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=ref(c,A3+1)>c and ref("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) and cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
RSI底背離:STICKLINE(FILTER(B3>0,5),0,0.5,3,0),COLORFFCC66;{5天內B3>0的條件不被記錄在內,在當前周期內出現B3>0畫青色柱線}
DRAWTEXT(FILTER(B3>0,5),0.25,'RSI底背離'),COLORFFCC66;
2,COLORRED;
C1:=BARSLAST(ref(cross("macd.dea"(12,26,9),"macd.diff"(12,26,9)),1));
D1:=ref(c,C1+1)<c and ref("macd.diff"(12,26,9),C1+1)>"macd.diff"(12,26,9) and cross("macd.dea"(12,26,9),"macd.diff"(12,26,9));
MACD頂背離:STICKLINE(FILTER(D1>0,5),2,1.25,3,0),COLOR0066FF;{5天內D1>0的條件不被記錄在內,在當前周期內出現D1>0畫橘黃色柱線}
DRAWTEXT(FILTER(D1>0,5),1.47,'MACD頂背離'),COLOR0066FF;
C2:=BARSLAST(ref(cross("kdj.d"(9,3,3),"kdj.k"(9,3,3)),1));
D2:=ref(c,C2+1)<c and ref("kdj.k"(9,3,3),C2+1)>"kdj.k"(9,3,3) and cross("kdj.d"(9,3,3),"kdj.k"(9,3,3));
KDJ頂背離:STICKLINE(FILTER(D2>0,5),2,1,3,0),COLORRED;{5天內D2>0的條件不被記錄在內,在當前周期內出現D2>0畫紅色柱線}
DRAWTEXT(FILTER(D2>0,5),1.2,'KDJ頂背離'),COLORRED;
C3:=BARSLAST(ref(cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=ref(c,C3+1)<c and ref("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) and cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
RSI頂背離:STICKLINE(FILTER(D3>0,5),2,1.5,3,0),COLORFF00FF;{5天內D3>0的條件不被記錄在內,在當前周期內出現D3>0畫粉色柱線}
DRAWTEXT(FILTER(D3>0,5),1.75,'RSI頂背離'),COLORFF00FF;
這是一個引用FILTER函數比較多的指標,請認真研究和體會一下語句的用法。
2、函數:SUMBARS 累加到指定周期數 向前累加到指定值到現在的周期數。 用法:SUMBARS(X,A),將X向前累加直到大于等于A,返回這個區間的周期數。 例如:
 

SUMBARS(VOL,CAPITAL),求完全換手到現在的周期數。
這個函數好用,在于它不但能精確地得到統計結果,而且能得到“模糊”的結果。
就以SUMBARS(VOL,CAPITAL)為例:
日期數:SUMBARS(VOL,CAPITAL);{返回成交量累加到流通盤的日期數}
驗證:SUM(V,日期數)/CAPITAL;{把返回的日期數之內的成交量累計,再除以流通盤}
運行的結果中,我們可以看到,“驗證”的輸出,除了SUMBARS起算點附近之外,從來沒有小于1的。可見SUMBARS只往多算,不往少算。請看下面指標:
Var1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
VarB:=SUM(IF(CLOSE>REF(CLOSE,7),VOL,IF(CLOSE<REF(CLOSE,7),0-VOL,0)),0);
VarC:=SUMBARS(VOL,CAPITAL);{求完全換手到現在的周期數}
VarD:=IF(CLOSE>LLV(CLOSE,VarC),1,-1);
VarE:=IF(VarB>LLV(VarB,VarC),1,-1);
VarF:=VarD*VarE;
Var10:=IF(VarF=-1,1,0);
關注:IF(Var10 AND CLOSE=LLV(CLOSE,20) AND Var3<12,70,1),colorffcc66;{在圖上0--70的坐標處顯示青色脈沖信號}
V1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),0-VOL,0)),0);
V2:=SUMBARS(VOL,CAPITAL);{求完全換手到現在的周期數}
V3:=IF(CLOSE>LLV(CLOSE,V2),1,-1);
V4:=IF(V1>LLV(V1,V2),1,-1);
V5:=V3*V4;
V6:=IF(V5=-1,1,0);
V7:=COUNT(V6=1,8)>2;
V8:=AMOUNT/VOL/100;
V9:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VA:=SUM(AMOUNT,13)/V8/100;
VB:=DMA(V9,VOL/VA);
VC:=(CLOSE-VB)/VB*100<-15;
VD:=(CLOSE-MIN(REF(CLOSE,5)*0.865,REF(CLOSE,21)*0.772))/CLOSE<0.05;
長針:(VC AND VD AND V7)*60,coloryellow;{在圖上0--60的坐標處顯示黃色脈沖信號}

  鄭重聲明:大智慧股民之家刊登〖大智慧公式教程:引用函數FILTER、SUMBARS運用〗一文目的在于傳播更多信息,與本網站立場無關。本版文章的原創性以及文中陳述文字和內容并未經過本站證實,大智慧股民之家不保證其內容的準確性、可靠性和有效性,僅供投資者參考,并不構成投資建議。投資者據此操作,風險自擔,并請自行核實相關內容。 如對本文內容有疑議,請及時與我們聯系。
分享到:

相關閱讀:

股票在線視頻:

江苏e球彩开奖走势图